Technical issue with Swedbank payments

Incident Report for Montonio

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 08:17 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2025 - 08:04 UTC

Update

We are continuing to investigate this issue.
Posted Apr 09, 2025 - 07:52 UTC

Investigating

Dear partner,

We regret to inform you that our payment methods is experiencing an outage as of 10:31 EEST. During this time, we are experiencing issues with Swedbank payments.

We're pleased to inform you that our technical team is already identifying and resolving the issue. Our service will soon be fully operational.

We apologize for any inconvenience this may cause!
Posted Apr 09, 2025 - 07:51 UTC
This incident affected: Payment methods (Estonian bank links, Latvian bank links, Lithuanian bank links).