Luminor Lithuania is experiencing technical difficulties

Incident Report for Montonio

Resolved

This incident has been resolved.
Posted Jun 27, 2024 - 12:06 UTC

Monitoring

Luminor is currently experiencing technical difficulties in Lithuania, service is currently down. Team is aware and is working to resolve it as soon as possible.
Posted Jun 27, 2024 - 11:29 UTC
This incident affected: Payment methods (Lithuanian bank links).