Technical issues with Citadele payments
Incident Report for Montonio
Resolved
The issue has now been resolved. Thank you for your patience.
Posted Jul 10, 2024 - 05:26 UTC
Identified
Dear partner!

We are currently experiencing issues with Citadele payments caused by a service disruption in the bank system. Citadele is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Jul 09, 2024 - 17:17 UTC
This incident affected: Payment methods (Estonian bank links, Latvian bank links, Lithuanian bank links).