Technical issues with Citadele payments
Incident Report for Montonio
Resolved
The issue has been resolved and payments are stable since yesterday 30.11.2022 17.20 EET. Thank you for your patience.
Posted Dec 01, 2022 - 08:08 UTC
Investigating
Dear partner,

We are currently experiencing issues with Citadele payments in all Baltic countries caused by a service disruption in the bank system. Citadele is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!

We will keep you updated on the matter. Thank you for your patience.
Posted Nov 30, 2022 - 13:28 UTC
This incident affected: Payment Initiation Service (Estonian payment links, Latvian payment links, Lithuanian payment links).