Technical issues with DPD labels
Incident Report for Montonio
Resolved
Dear partner,

All technical difficulties with our shipping service have been eliminated and label printing works regularly.
We are sorry for the inconveniences!
Posted Jan 17, 2023 - 18:50 UTC
Investigating
Dear partner,

Due to a recent system update we are experiencing technical issues with DPD labels and tracking numbers. At the moment the printing of DPD labels has limited performance. We are sorry for the inconvenience!

We are working on fixing the solution and will keep you updated as soon as possible.
Posted Jan 17, 2023 - 15:52 UTC
This incident affected: Shipping Service.