Luminor is experiencing technical difficulties
Incident Report for Montonio
Resolved
This incident has been resolved.
Posted Jun 27, 2024 - 08:51 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 27, 2024 - 06:53 UTC
Monitoring
Luminor is currently experiencing technical difficulties in all three Baltic countries, service is not down but having intermittent issues. Team is working to resolve it as soon as possible.
Posted Jun 27, 2024 - 06:45 UTC
This incident affected: Payment methods (Estonian bank links, Latvian bank links, Lithuanian bank links).