Technical issues with Nordea payments
Incident Report for Montonio
Resolved
The issue has now been resolved. Thank you for your patience.
Posted Nov 14, 2022 - 10:39 UTC
Investigating
Dear partner!

We are currently experiencing issues with Nordea payments caused by a service disruption in the bank system. Nordea is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Nov 14, 2022 - 07:20 UTC
This incident affected: Payment Initiation Service (Finnish payment links).