Technical issues with Citadele payments
Incident Report for Montonio
Resolved
The issue has now been resolved. Thank you for your patience.
Posted Mar 13, 2023 - 17:47 UTC
Investigating
Dear partner!

We are currently experiencing issues with Citadele payments in Latvia and Lithuania caused by a service disruption in the bank system. Citadele is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Mar 13, 2023 - 14:13 UTC
This incident affected: Payment methods (Latvian bank links, Lithuanian bank links).