Technical issues with Swedbank Latvia payments
Incident Report for Montonio
Resolved
This incident has been resolved.
Posted Aug 27, 2024 - 09:57 UTC
Investigating
Dear partner!

We are currently experiencing issues with Swedbank Latvia payments caused by a service disruption in the bank system. Swedbank Latvia is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Aug 27, 2024 - 09:49 UTC
This incident affected: Payment methods (Latvian bank links).