Technical issues with SEB payments

Incident Report for Montonio

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 19:50 UTC

Investigating

Dear partner!

We are currently experiencing issues with SEB payments caused by a service disruption in the bank system. SEB is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Apr 11, 2025 - 19:17 UTC
This incident affected: Payment methods (Estonian bank links, Latvian bank links, Lithuanian bank links).