Technical issues with Šiaulių payments
Incident Report for Montonio
Resolved
The issue has now been resolved. Thank you for your patience.
Posted Jul 13, 2024 - 08:44 UTC
Identified
Dear partner!

We are currently experiencing issues with Šiaulių payments caused by a service disruption in the bank system. Šiaulių is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Jul 13, 2024 - 07:12 UTC
This incident affected: Payment methods (Lithuanian bank links).