Technical issues with Danske Bank payments

Incident Report for Montonio

Resolved

The issue has now been resolved. Thank you for your patience.
Posted Apr 21, 2025 - 17:11 UTC

Monitoring

Dear partner!

We are currently experiencing issues with Danske Bank payments caused by a service disruption in the bank system. Danske Bank is investigating the issue and will deploy a fix as soon as possible. We apologise for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Apr 21, 2025 - 14:10 UTC
This incident affected: Payment methods (Finnish bank links).