Technical issues with Säästöpankki, Oma Säästöpankki and POP Pankki payments
Incident Report for Montonio
Resolved
The issue has now been resolved. Thank you for your patience.
Posted Dec 13, 2022 - 19:33 UTC
Investigating
Dear partner!

We are currently experiencing issues with Säästöpankki, Oma Säästöpankki and POP Pankki payments caused by a service disruption in the bank systems. Savings Group support team is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Nov 25, 2022 - 17:01 UTC
This incident affected: Payment Initiation Service (Finnish payment links).