Technical issues with SEB payments

Incident Report for Montonio

Resolved

This incident has been resolved.
Posted Mar 04, 2025 - 11:22 UTC

Investigating

Dear partner!

We are currently experiencing issues with SEB payments caused by a service disruption in the bank system. SEB is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Mar 04, 2025 - 11:12 UTC
This incident affected: Payment methods (Lithuanian bank links).