Luminor Bank service maintenance

Incident Report for Montonio

Resolved

The issue has now been resolved. Thank you for your patience.
Posted 1 month ago. Jan 29, 2025 - 07:38 UTC

Monitoring

Luminor Bank will perform scheduled extensive IT maintenance work tonight 28.01 from 22:30 till 03:00 in the core banking system. Therefore, during this period Payment initiation services in Luminor Bank will not be available.
Posted 1 month ago. Jan 28, 2025 - 20:59 UTC
This incident affected: Payment methods (Estonian bank links, Latvian bank links, Lithuanian bank links).