Technical issues with S-Pankki payments
Incident Report for Montonio
Resolved
The issue has now been resolved. Thank you for your patience.
Posted Nov 17, 2022 - 15:30 UTC
Investigating
Dear partner!

We are currently experiencing issues with S-Pankki payments caused by a service disruption in the bank system. S-Pankki is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Nov 17, 2022 - 12:38 UTC
This incident affected: Payment Initiation Service (Finnish payment links).