Smart-ID and Mobile-ID are experiencing technical difficulties

Incident Report for Montonio

Resolved

This incident has been resolved.
Posted Dec 30, 2025 - 09:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 30, 2025 - 09:19 UTC

Identified

Smart-ID and Mobile-ID currently experiencing technical difficulties in all three Baltic countries and logging in to services using Smart-ID or Mobile-ID might not be possible. More information can be found on SK ID Solutions status page at https://status.sk.ee/
Posted Dec 30, 2025 - 09:12 UTC
This incident affected: Payment methods (Estonian bank links, Latvian bank links, Lithuanian bank links) and Financing & Pay later services, Partner system.