Technical issues with Luminor payments

Incident Report for Montonio

Resolved

This incident has been resolved.
Posted Feb 06, 2025 - 22:15 UTC

Monitoring

Dear partner,

We are currently experiencing issues with Luminor payments in Lithuania caused by a service disruption in the bank system. Luminor is investigating the issue and will deploy a fix as soon as possible. We apologise for any inconvenience this may cause and will notify you once the issue is resolved!

We will keep you updated on the matter. Thank you for your patience.
Posted Feb 06, 2025 - 21:03 UTC
This incident affected: Payment methods (Lithuanian bank links).