Technical issues with Swedbank payments
Incident Report for Montonio
Resolved
The issue has now been resolved. Thank you for your patience.
Posted Mar 23, 2023 - 18:05 UTC
Investigating
Dear partner,

We are currently experiencing issues with Swedbank payments in all Baltic countries caused by a service disruption in the bank system. Swedbank is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!

PS! Swedbank local internet banking websites are also down and not responding.

We will keep you updated on the matter. Thank you for your patience.
Posted Mar 23, 2023 - 16:37 UTC
This incident affected: Payment methods (Estonian bank links, Latvian bank links, Lithuanian bank links).