Luminor service maintenance
Incident Report for Montonio
Resolved
This incident has been resolved.
Posted Jul 25, 2024 - 08:15 UTC
Monitoring
Luminor (EE, LV, LT) will perform scheduled extensive IT maintenance work tomorrow morning 2024-07-25 from 02:30 AM till 05:00 AM in the core banking system. Therefore, during this period Payment initiation services in Luminor will not be available.
Posted Jul 24, 2024 - 08:13 UTC
This incident affected: Payment methods (Estonian bank links, Latvian bank links, Lithuanian bank links).