Technical issues with printing Itella labels
Incident Report for Montonio
Resolved
Itella services are now working through Montonio.
Posted Nov 14, 2022 - 14:05 UTC
Identified
Dear partner,

Due to the security breach that Itella had on 07.11 they are now experiencing technical issues. Currently all Itella solutions are working in limited capacity. Due to this, printing Itella labels is not possible through Montonio.

Itella is working on fixing the solution, but they have communicated at least 1-2 days for the fix.

In the mean time, we suggest to wait with printing Itella shipments and send them out after the system is fixed. Or if you wish to send out parcels faster, then use Omniva or DPD to ship these packages

We will keep you updated once we have more information.
Posted Nov 08, 2022 - 11:50 UTC
This incident affected: Shipping service.