Technical issues with Santander Bank payments
Incident Report for Montonio
Resolved
The issue has now been resolved. Thank you for your patience.
Posted Jan 29, 2025 - 15:39 UTC
Monitoring
Dear partner!

We are currently experiencing issues with Santander Bank payments caused by a service disruption in the bank system. Santander Bank is investigating the issue and will deploy a fix as soon as possible. We apologise for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Jan 29, 2025 - 14:25 UTC
This incident affected: Payment methods (Polish bank links).