Technical issues with DPD shipments

Incident Report for Montonio

Resolved

This incident has been resolved.
Posted Nov 26, 2025 - 13:02 UTC

Monitoring

Dear partner!

We are currently experiencing issues with DPD shipments caused by a service disruption in their shipping system. DPD is investigating the issue. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Nov 26, 2025 - 12:34 UTC
This incident affected: Shipping service.