Smart-ID is experiencing technical difficulties

Incident Report for Montonio

Resolved

The issue has now been resolved. Thank you for your patience.
Posted Mar 10, 2025 - 17:32 UTC

Monitoring

Smart-ID is currently experiencing technical difficulties in all three Baltic countries and logging in to services using Smart-ID might not be possible. More information can be found on SK ID Solutions status page at https://status.sk.ee/
Posted Mar 10, 2025 - 17:11 UTC
This incident affected: Payment methods (Estonian bank links, Latvian bank links, Lithuanian bank links) and Financing & Pay later services, Partner system.