Technical issues with Swedbank payments
Incident Report for Montonio
Resolved
Dear partner,

Swedbank confirms that they have fixed the issue and that customers are again able to make payments. The bank apologizes for the inconvenience.
Posted Nov 26, 2022 - 23:55 UTC
Investigating
Dear partner,

We are currently experiencing issues with Swedbank payments in all Baltic countries caused by a service disruption in the bank system. Swedbank's support team is investigating the issue. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!

We will keep you updated on the matter. Thank you for your patience.
Posted Nov 26, 2022 - 20:37 UTC
This incident affected: Payment Initiation Service (Estonian payment links, Latvian payment links, Lithuanian payment links).