Technical issues with Ing Poland payments
Incident Report for Montonio
Resolved
This incident has been resolved.
Posted Nov 30, 2024 - 15:49 UTC
Monitoring
Dear partner!

We are currently experiencing issues with Ing Poland payments caused by a service disruption in the bank system. Ing Poland is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Nov 30, 2024 - 15:32 UTC
This incident affected: Payment methods (Polish bank links).