Technical issues with LHV payments

Incident Report for Montonio

Resolved

This incident has been resolved.
Posted Mar 20, 2025 - 15:22 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 20, 2025 - 12:54 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2025 - 12:38 UTC

Investigating

Dear partner!

We are currently experiencing issues with LHV payments caused by a service disruption in the bank system. LHV is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Mar 20, 2025 - 12:08 UTC
This incident affected: Payment methods (Estonian bank links).