Technical issues with Citadele bank payments
Incident Report for Montonio
Resolved
This incident has been resolved.
Posted Nov 02, 2024 - 12:41 UTC
Investigating
Dear partner!

We are currently experiencing issues with Citadele bank payments caused by a service disruption in the bank system. Citadele bank is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Nov 02, 2024 - 11:54 UTC
This incident affected: Payment methods (Latvian bank links).