Technical issues with Citadele payments
Incident Report for Montonio
Resolved
This incident has been resolved.
Posted Nov 25, 2024 - 17:53 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 25, 2024 - 16:51 UTC
Monitoring
Dear partner!

We are currently experiencing issues with CITADELE payments caused by a service disruption in the bank system. Citadele is investigating the issue and will deploy a fix as soon as possible. We apologize for any inconvenience this may cause and will notify you once the issue is resolved!
Posted Nov 25, 2024 - 12:31 UTC
This incident affected: Payment methods (Estonian bank links, Latvian bank links, Lithuanian bank links).